마스터Q&A 안드로이드는 안드로이드 개발자들의 질문과 답변을 위한 지식 커뮤니티 사이트입니다. 안드로이드펍에서 운영하고 있습니다. [사용법, 운영진]

kotlin sdk 버전은 몇을 쓰는게 좋을까요 ?..

0 추천
kotlin sdk 버전은 몇을 쓰는게 좋을까요 ?..

 

작년에 aos 를 인계 받아서 ( 그때부터 aos 개발 시작함 ㅋ - iOS 개발자임..)

진행중에 있습니다.

당시 kotlin 1.6.22 이고, api minSDK 28로 처리되어 있습니다.

그런데 .. 내부 코딩에 compose 를 적용하려고 했더니 .. kotlin 1.7.0 이상으로 업데이트 하라고 나오더군요 ..

그래서 이참에 업데이트 하려고 하는데 ..

적정 kotlin 버전이 현재 기준으로 어디까지 올리는게 좋을까요 .. (현재 최신은  1.9.22 로 나오네요 .. )

 

조언 구합니다 ~^^

 

ㅋㅋ chatGPT에게 물어보니 ,, 그냥 1.9.22 까지 올리라는데 .. 그래도 되려나요 ㅎㅎ
창현아빠 (200 포인트) 님이 1월 31일 질문
창현아빠님이 1월 31일 수정

1개의 답변

0 추천
가능하다면. 최신 안정버전을 사용하시면 될 것 같습니다.  버전이 너무 급히 올라가면 deprecated되거나 하는 부분들이 있어서 수작업은 좀 하셔야 할겁니다. 그리고 제 기억에 코틀린 1,9.22 면 자바는 17을 사용하셔야 할거예요.

아래 맵핑 테이블도 참고하세요.

https://developer.android.com/jetpack/androidx/releases/compose-kotlin
spark (223,680 포인트) 님이 2월 10일 답변
...